Register now to get rid of these ads!

Hot Rods Popping through my exhaust

Discussion in 'The Hokey Ass Message Board' started by 52chev, Nov 10, 2017.

  1. 52chev
    Joined: Jun 22, 2006
    Posts: 44

    52chev
    Member

    I have a sbc running 6 x 97s on an edelbrock X1 manifold. It has fenderwell headers and a full exhaust. While just crusing along its popping through the exhaust... but not under load. Any ideas?cheers

    Sent from my SM-G360G using The H.A.M.B. mobile app
     
  2. What ignition are you running does it use vacuum advance,did it just start popping?

    Sent from my SM-G900V using The H.A.M.B. mobile app
     
  3. Lean miss
    Exhaust leak can cause that too
     
    52chev likes this.
  4. oj
    Joined: Jul 27, 2008
    Posts: 6,056

    oj
    Member

    'Pull-over' thru the accelerator pump causing droplets of fuel to dribble into the venturii from the squirter. Fuel level is too high in one of the carbs allowing the fuel to flow too easily, the fuel weight (volume) in the bowl and the higher level lets the fuel flow when it shouldn't and minute drops enter the venturii from the squirter, they are large enough that the engine can't burn them and pop thru the exhaust.
    Lots of other things it could be as well. When you shut the engine off do you see whiteish vapor curling up from any of the carbs? Thats the one with the float too high.
     
    pitman likes this.
    Register now to get rid of these ads!

  5. 52chev
    Joined: Jun 22, 2006
    Posts: 44

    52chev
    Member

    Running msd ignition. Only started since installing the 97s. ... used to run one 4 barrel quick fuel while running it in and it was fine.

    Sent from my SM-G360G using The H.A.M.B. mobile app
     
  6. 52chev
    Joined: Jun 22, 2006
    Posts: 44

    52chev
    Member

    Cheers. Re did all gaskets...no change... must be in the carbs....

    Sent from my SM-G360G using The H.A.M.B. mobile app
     
  7. 52chev
    Joined: Jun 22, 2006
    Posts: 44

    52chev
    Member

    Cheers. I will go check those things... haven't seen any smoke when it turns off..... it only pops while cruising... at idle and under load it's fine...

    Sent from my SM-G360G using The H.A.M.B. mobile app
     
  8. oj
    Joined: Jul 27, 2008
    Posts: 6,056

    oj
    Member

    The vapor thing is only seen under certain conditions, temperature sensative. Like vapor rising off a pond.
     
  9. ghornbostel
    Joined: Jan 3, 2012
    Posts: 131

    ghornbostel
    Member

    My 3C IDA Weber’s do this. I pull the tops off and clean the orange sediment from the float bowls and it’s good till next time. Now that I have the car pulled down to the frame I’ll replace the original fuel line as I’ve lined the fuel tank already. This stuff is so fine it gets by a filter
    Greg


    Sent from my iPhone using H.A.M.B.
     

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2020 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.