Register now to get rid of these ads!

Technical Edelbrock hot start problem , UPDATE

Discussion in 'The Hokey Ass Message Board' started by chainsaw, Feb 21, 2019.

  1. I would bump up your fuel pressure to 5.5, I've been running that for 12 years on a low profile 2x4 setup, with stock mechanical fuel pump. The only time mine is hard to start is when it sits a couple months, other than that I just barely crack the throttle, hit the key and boom, starts right up, points distributor and stock coil.
     
  2. Tum Taylor
    Joined: Mar 3, 2019
    Posts: 4

    Tum Taylor

    By hard start are you saying it cranks fine but just wont start? Or slow cranks like a bad starter or battery? I had a slow crank issue when warmed up, threw all kinds if stuff at it. Found a melted to a header battery to starter cable...
     
  3. OLDSMAN
    Joined: Jul 20, 2006
    Posts: 1,808

    OLDSMAN
    Member

    Last summer I replaced the Q-jet with an Edelbrock carb and manifold on my convertible and couldn't be happier with the way it performs. It starts better after sitting for months than before, and I had no hard start when hot problems last summer
     
  4. Cranks fine just sputters for awhile till it hits. Still 22 degrees outside,working on car is on hold for a while
     
  5. Put in insulators, rerouted gas line and rechecked floats. Floats were fine. Starts alot better now when hot but the temp outside hasnt been above 75 yet. Have to see what happens when it gets to over 100 here. Thanks for all the help guys.
     
  6. Lee Veinotte
    Joined: Feb 6, 2019
    Posts: 142

    Lee Veinotte

    I had fuel boiling in my Edelbrock as well. 1 inch spacer cured it.
     
    olscrounger likes this.
  7. primed34
    Joined: Feb 3, 2007
    Posts: 923

    primed34
    Member

    Spacer worked for me.
     
  8. sdluck
    Joined: Sep 19, 2006
    Posts: 2,176

    sdluck
    Member

    This is on a tunnel ram,i don't think it is vapor lock
     
    swade41 and egads like this.
  9. Have you checked your ignition yet?
     
  10. Pulled # 5 plug wire ,put in screwdriver and had spark jump when hot. If its true the area over the trans tunnel is the hottest spot then I think rerouting the fuel lines was the problem.
     

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2020 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.