Register now to get rid of these ads!

Technical Sun Tach gremlins...Anybody had this problem?

Discussion in 'The Hokey Ass Message Board' started by powrshftr, Jun 7, 2014.

  1. powrshftr
    Joined: Mar 29, 2013
    Posts: 4,550

    powrshftr
    Member

    Hi Guys,
    I was hoping somebody else has had this problem,and that maybe I just made a simple error during installation.
    I've got an old Sun tach with the narrow sweep dial (160 degrees or so?).I will post some pictures of it later today to show exactly which model it is.
    Anyway,the problem is,it will read nice and accurate at idle,and it will read up to 3000 rpm,then it just kind of goes into spasms after it gets to 3 grand.....the needle will not go over three grand unless its just in quick twitches.

    It did this when I still had the Accel points distributor,and its doing it now with theMSD stuff too.

    I bought the MSD tach adaptor kit,but have not installed it yet,because I think its definitely a problem with the tach.
    It's in really nice shape visually,but this problem is driving me nuts,as I need to get the car working properly for the Meltdown!

    Any thoughts,advice,related experience,or assistance would really help me out at this point.

    Thanks a bunch,

    Scott


    Posted using two Dixie cups and a medium length piece of string.
     
  2. OldColt
    Joined: Apr 7, 2013
    Posts: 504

    OldColt
    Member

    I've experienced a similar problem with a full sweep Sun Tachometer and an old MSD5 box. Mine went totally erratic over 7000 RPM. Problem turned out to be point bounce. It wasn't enough to hear a miss, but the tach would go wacky. Modifying the points for more spring pressure to the dizzy lobes solved the problem.

    --- Steve ---
     
  3. powrshftr
    Joined: Mar 29, 2013
    Posts: 4,550

    powrshftr
    Member

    Thanks oldcolt,but I'm still not sure what's happening,as I went from a points distributor and no Msd box,to an electronic Msd distributor and 6AL box....I'm thinking the tach might be fucky, or is it possible I have a 6cyl tach or something screwy?

    Scott


    Posted using the Full Custom H.A.M.B. App!
     
  4. gas pumper
    Joined: Aug 13, 2007
    Posts: 2,956

    gas pumper
    Member

    I've had and have similar issues with multiple tachs and two distributors and with or with out a high output ignition system. In my case I believe it is interference from the ignition wires since that is all that has been a constant. And I have not changed wires.
     

  5. You dont say which transmitter box you are using...an 8 cyl 12 volt uses a EB-9 box
     
  6. powrshftr
    Joined: Mar 29, 2013
    Posts: 4,550

    powrshftr
    Member

    This one doesn't use a box.....at least the guy at Carlisle swap meet 20 yrs ago didn't think it did...

    Here's a picture of the tach:
    ImageUploadedByH.A.M.B.1402160001.157291.jpg

    Scott


    Posted using the Full Custom H.A.M.B. App!
     
  7. powrshftr
    Joined: Mar 29, 2013
    Posts: 4,550

    powrshftr
    Member

    You may be onto something with the wires.....?I will try to borrow another set to test.

    Thanks,

    Scott


    Posted using the Full Custom H.A.M.B. App!
     
  8. Dont take the sellers word for it...Call Williamsons in Chester,Arkansa,,From the face it says its a ST-602...model #
    so may be for a 6 cyl...
    Williamson Instruments...Best restorer of old Sun Tachs
     
  9. powrshftr
    Joined: Mar 29, 2013
    Posts: 4,550

    powrshftr
    Member

    Thanks!I will give them a call bright and early Monday morning.

    I'd rather get this one repaired or updated than get a new one.This thing has a ton of character.:)

    Scott


    Posted using the Full Custom H.A.M.B. App!
     
  10. Muttley
    Joined: Nov 30, 2003
    Posts: 18,465

    Muttley
    Member

    Absolutely. I had an old Sun Blue Line converted by them 5 years ago, I would recommend them to anyone.
     
  11. kuhn1941
    Joined: Feb 15, 2013
    Posts: 194

    kuhn1941
    Member

    I did have the tach jump problem before when I changed an engine in a vehicle . Turned out the new spark plugs I put in were bad , I installed ngk's then the problem gone . I was shocked and suprised . Goodluck

    Posted using the Full Custom H.A.M.B. App!
     
  12. powrshftr
    Joined: Mar 29, 2013
    Posts: 4,550

    powrshftr
    Member

    Hey guys,
    Thanks for all the replies.Its crazy how temperamental electronics can be.
    Sending the tach out bright and early Monday morning,hopefully get it back way before the Meltdown:)

    Scott


    Posted using the Full Custom H.A.M.B. App!
     
  13. powrshftr
    Joined: Mar 29, 2013
    Posts: 4,550

    powrshftr
    Member

    Left a message with them this morning.....we'll see how it goes:)

    Scott


    Posted using the Full Custom H.A.M.B. App!
     
  14. powrshftr
    Joined: Mar 29, 2013
    Posts: 4,550

    powrshftr
    Member

    Sent the tach out yesterday to Williamson's.
    Talked to Ron for a few minutes on the phone before sending.
    What a great guy,both as a craftsman,and a human being.

    Can't wait to get the finished product back,and try it out on the car!

    Scott


    Posted using the Full Custom H.A.M.B. App!
     
  15. 56shoebox
    Joined: Sep 14, 2011
    Posts: 1,106

    56shoebox

    What does Ron think the problem is? Did he verify on the phone that it is indeed a 8 cylinder tach and not a 6, as suspected earlier in the postings?
     
  16. powrshftr
    Joined: Mar 29, 2013
    Posts: 4,550

    powrshftr
    Member

    Shoebox:
    Ron's concern was mainly that the movement would need to be replaced,as the points ignition the tach was designed for operated on a square wave,whereas the electronic Msd unit and distributor operate on a peaked wave.
    The problem was happening while I still had a points distributor and no Msd though,so I will mention it to Ron.
    It will be interesting to see what he finds when he pulls it apart.

    Scott


    Posted using the Full Custom H.A.M.B. App!
     
  17. big duece
    Joined: Jul 28, 2008
    Posts: 6,315

    big duece
    Member
    from kansas

    As we speak, Ron is doing a conversion on a tach and sun transmitter box also. He gave me a generious amount of time on the phone to make sure I was getting exactly what I needed. I am so glad there are still guys in these specialty fields that take the time to work with the customer.
     
    powrshftr likes this.
  18. Ole don
    Joined: Dec 16, 2005
    Posts: 2,915

    Ole don
    Member

    I hate to say it outright, but I dont think those tachometers are very good. I ran one for years, and it seemed very accurate. When on a long trip though, after driving eight to ten hours, it lost accuracy. It seemed to get hot after that long, and not from the sun. It would gradually loose RPMs at the same cruising speed. The next day, it would start out fine, then after about four PM, it would loose RPMs again. A switch to a Auto Meter tach solved the problem.
     
  19. 283john
    Joined: Nov 17, 2008
    Posts: 853

    283john
    Member

    I thought my tach was getting erratic over 7,000 rpm once. Turns out it was just all the chunks of connecting rod flying through my oilpan.
     
    powrshftr likes this.
  20. powrshftr
    Joined: Mar 29, 2013
    Posts: 4,550

    powrshftr
    Member

    Ole Don:
    With Ron completely changing out the movement in the thing,it's gonna be a brand new tach in a nice looking vintage case anyway.

    And with 4.56 gears,I can't see myself taking many trips with this thing that last 4 hours.....hoping for more like 12 seconds!;)

    Scott


    Posted using the Full Custom H.A.M.B. App!
     
  21. DAVEG2
    Joined: Feb 27, 2010
    Posts: 332

    DAVEG2
    Member

    I had Williamson's do 2 old Sun tachs last year. Very nice people.
     
  22. big duece
    Joined: Jul 28, 2008
    Posts: 6,315

    big duece
    Member
    from kansas

    Were you using a sun transmitter box than ran on batteries? The new converted style is powered by consistant 12v.
     
  23. powrshftr
    Joined: Mar 29, 2013
    Posts: 4,550

    powrshftr
    Member

    Should have the tach back,and on the car within a week....Will post an update when I get it installed for a test drive.

    Scott


    Posted using the Full Custom H.A.M.B. App!
     
  24. powrshftr
    Joined: Mar 29, 2013
    Posts: 4,550

    powrshftr
    Member

    Tach is on the way back,Ron did a TON of extra work at zero extra cost to me....Fantastic guy,just don't expect him to sit around and chit chat on the phone,he has work to do....lol

    Scott


    Posted using the Full Custom H.A.M.B. App!
     
  25. powrshftr
    Joined: Mar 29, 2013
    Posts: 4,550

    powrshftr
    Member

    Got it back today,and it is absolutely beautiful!

    Taking it out to try it tomorrow night:)
    ImageUploadedByH.A.M.B.1409098268.975751.jpg

    Scott


    Posted using the Full Custom H.A.M.B. App!
     
    Muttley likes this.

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2021 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.