Register now to get rid of these ads!

Odometer working - speedo not

Discussion in 'The Hokey Ass Message Board' started by turdmagnet, May 23, 2012.

  1. turdmagnet
    Joined: May 19, 2008
    Posts: 356

    turdmagnet
    Member

    Driving the other day my speedometer stopped working, but the odometer still turns. The speedo has always registered accurate and very smooth, but as I was driving it just dropped to the bottom and stays there. I do hear a slight grinding or sliding noise coming from it now.

    Is there anything quick to check for, or is it in need of professional help ? Its in a 51 Pontiac.

    Thanks much !!!!
     
  2. e1956v
    Joined: Sep 29, 2009
    Posts: 1,296

    e1956v
    Alliance Vendor

    Sounds like the speedcup is broken (it is connected to the shaft that the speedometer needle rides on). It will need to come out and be repaired. Check for a local speedo shop in your area (support your local shops) If you can not find anyone local PM me or check our website.
     
  3. Flatman
    Joined: Dec 20, 2005
    Posts: 1,975

    Flatman
    Member

    Try Metro Tachograph in Etobicoke (416)236-2495, I've heard they're good.

    Flatman
     
  4. dirty old man
    Joined: Feb 2, 2008
    Posts: 8,092

    dirty old man
    ALLIANCE MEMBER

    X2
    Dave
     
    Register now to get rid of these ads!

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2020 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.