Register now to get rid of these ads!

need help with turn signal wiring

Discussion in 'The Hokey Ass Message Board' started by 1962falcon, Jul 25, 2010.

  1. 1962falcon
    Joined: Apr 24, 2010
    Posts: 28

    1962falcon
    Member

    Ok so I'm installing a new turn signal switch to try and fix brake light problem I was having. Well I got the switch in place and there's six wires coming from the switch, used a test light and found the brake light and other stuff, I hooked everything up and now my brake lights work everything works, tailights, brake lights, right blinker, EXCEPT the left blinker, now when I turn the left blinker on the left blinker doesn't work nor does the brake lights. Does anyone have a wiring diagram I could try to follow to make sure all my wires are plugged into the right place or any suggestions. The car is a 1962 ford falcon
     
  2. 1962falcon
    Joined: Apr 24, 2010
    Posts: 28

    1962falcon
    Member

  3. lolife
    Joined: May 23, 2006
    Posts: 1,123

    lolife
    Member

    Get a trickle-charger so you don't burn down the car.

    Identify each of the wires. You should have 1 parking light wire, 2 turn signal wires to the front, and 1 tail-light wire to the rear, and 2 turn signal/brake light wires to the rear.

    The turn signal lights will use the brighter element of the bulb - duh.

    This is where it gets complicated. The switch will have power going in, and it then switches this power to several wires. Two of these wires will go to the blinker relay. Using a test light, you should be able to figure this all out in less than 5 minutes.

    Start off by using your trickle-charger on the left turn signal lights. You may just have a bad ground there.
     
  4. robt500
    Joined: Nov 6, 2006
    Posts: 432

    robt500
    Member
    from Lex, KY

    wish I had a diagram for you but I don't. Maybe on another computer. I'm on my third turn signal switch in a '65 Fairlane 500. You're on the right path with the test light, inspect the new switch itself. I mail ordered one in the past that had a manufacturing defect. One of the contacts was so very slightly buried in plastic.
     
    Register now to get rid of these ads!

  5. Rewired
    Joined: Mar 19, 2006
    Posts: 138

    Rewired
    Member
    from Fresno

  6. UPSrodder
    Joined: Jun 9, 2005
    Posts: 566

    UPSrodder
    Member

  7. 1962falcon
    Joined: Apr 24, 2010
    Posts: 28

    1962falcon
    Member

    Alright got the problem fixed! Thanks for everyones help, I swear I don't know what I would do without the hamb!
     
  8. need louvers ?
    Joined: Nov 20, 2008
    Posts: 12,911

    need louvers ?
    Member

    Bad ground? Just curious...
     
  9. 1962falcon
    Joined: Apr 24, 2010
    Posts: 28

    1962falcon
    Member

    I had a couple of wires plugged into the wrong place, couldn't really go by color code because the wires were so old colors faded but was able to fix it due to a wiring diagram I downloaded from the link rewired posted
     

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2020 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.