Register now to get rid of these ads!

Need help - dead 56 Chevy

Discussion in 'The Hokey Ass Message Board' started by rbonazzoli, Feb 1, 2013.

  1. str8axle55
    Joined: Dec 19, 2006
    Posts: 355

    str8axle55
    Member
    from MA

    I`ve never had a Mallory that worked correctly. I swapped out the last one with a points dist with a Pertronix conversion. Glad you got it up and running.
     
  2. Dan Timberlake
    Joined: Apr 28, 2010
    Posts: 1,255

    Dan Timberlake
    Member

    "When it quits, the tach drops like it was disconnected even though the engine is still spinning."

    That is a Pretty powerful symptom pointing to ignition.
    When my turbocharged Corvair's tach wavered the slightest bit I knew it was to re-gap (and clean) the points.
     
  3. rbonazzoli
    Joined: Feb 16, 2012
    Posts: 141

    rbonazzoli
    Member
    from Dallas, TX


    Yes, agreed. That is what originally sent me down the path of ignition being the problem.
     
  4. rbonazzoli
    Joined: Feb 16, 2012
    Posts: 141

    rbonazzoli
    Member
    from Dallas, TX

    An interesting post-script to this problem. The coil died today. Now I suspect that the coil caused the Unilite to blow. In any case, I have the old GM style can coil in it now, and with the points distributor it runs great. No more electronic stuff for me, unless it is a GM HEI, which unfortunately will not fit without firewall mods.
     
  5. See my post #5... I'm right once in a while. Gonna print this out to show my wife...

    Bob
     
  6. rbonazzoli
    Joined: Feb 16, 2012
    Posts: 141

    rbonazzoli
    Member
    from Dallas, TX

    Ano, to je pravda. Dekuji!
     

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2020 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.