Register now to get rid of these ads!

My Caddy Sucks!!

Discussion in 'The Hokey Ass Message Board' started by jfrolka, May 20, 2008.

  1. jfrolka
    Joined: Oct 4, 2007
    Posts: 897

    jfrolka
    Member

    Got a 64 coupe with a 429 and im having nothing but trouble with it. I took the heads off of it awhile back and had the valve seats cut and lapped in the old valves and put the heads back together. The cylinder wall didnt have a lip in it and showed some cross hatching in the cylinder wall so i stopped there and just went about cleaning it up. When i took the lifter valley cover off and the oil pan it had a grey sludge (lead from old leaded gasoline i was told) in it so i diluted it by pouring oil on it and watched it loosen and i wiped it out. I soaked the oil pickup tube and it put that back in. I took the oil pump unit apart and degreased and soaked all that several times to make sure it was all clean. Put it all back together blocking off the egr ports to the intake manifold and on the carb side too. Primed it for awhile and made sure i saw oil everywhere and i get it in and running and i got a ticking noise with low oil pressure and it gets warm fast. One guy suggests i may have put the head gaskets on upside down. Any more ideas as to what problems I got??? Am i floating my valves? Not to mention it doesnt rev up high and its bogging at like 5/8 throttle!
     
  2. Abomination
    Joined: Oct 5, 2006
    Posts: 6,701

    Abomination
    Member

    ..EGR?

    Wow, dude... you should spend some phone time with Chris at http://www.cad500parts.com . He knows a LOT about the late 390/early 429.

    I'm trying to figure out what you blocked off... that motor SURELY has no EGR, man.

    Pics?

    ~Jason
     
  3. 40StudeDude
    Joined: Sep 19, 2002
    Posts: 9,461

    40StudeDude
    Member

    Yeah...if it's a '64...that is waaaaa-aaaaay pre-smog...you've blocked something that don't need no blocking...

    R-
     
  4. Dyce
    Joined: Sep 12, 2006
    Posts: 1,917

    Dyce
    Member

    The grey sludge you washed out of the valley is babit worn off your bearings. Did you check the bearings? Bearings are offered through sealed power yet I'm sure. Just don't make things worst by.

    The exhaust you blocked off heats the carb and helps with cold start. No egr valves in '64.
     

  5. Abomination
    Joined: Oct 5, 2006
    Posts: 6,701

    Abomination
    Member

    AND it's F'n DELICIOUS. That's all I've got to say...

    :p

    ~Jason

     
  6. str8Pipe65's
    Joined: Oct 10, 2007
    Posts: 272

    str8Pipe65's
    Member

    i feel your pain- i just rebuilt my 429 in my 65 cad- and those motors are super finecky-are you getting pinging or valve tapping- if so like above you might of plug something you didn't need to- plus the cold start warm up that was blocked. you can also try caddy daddy at 707-252-2339 later!
     
  7. LUX BLUE
    Joined: May 23, 2005
    Posts: 4,407

    LUX BLUE
    Alliance Vendor
    from AUSTIN,TX

    The grey shit could be nothing...
    But I betcha the tapping is coming from worn out rocker shafts.
    hell, even the pushrods wear on old caddy stuff. But the rocker shafts and rocker arms seem to be the usual suspects.

    Who died and made me Mr.Caddy? I don't know, but he can take this shit back. We are working on 3 of these miserable bastards right now.:D
     
  8. jfrolka
    Joined: Oct 4, 2007
    Posts: 897

    jfrolka
    Member

    Well all the stuff for the exhaust heat was gone and it had an edelbrock carb on it when i got it. I opted to block the exhaust heat port off with a plate sandwiched between the head and intake manifold and then i blocked off the two ports under carb on the intake manifold. Lots of guys on another cadillac website swapping to edelbrocks block off what I did and didnt encounter any problems. BUT I am running the stock carter carb with an electric choke. It ticked like an s.o.b :confused:

    Anyways I'm just gonna bite the big one and pull it out again and completely go through it with somebody experienced. I wanna know what is going wrong with it. Cylinder wall is still beautiful so looks like bearings and a full valvetrain job, fast 1000 bux!!! damn cadillacs!!:mad:
     

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2021 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.