Register now to get rid of these ads!

Projects My 53 Build,

Discussion in 'The Hokey Ass Message Board' started by Harris, Apr 29, 2012.

  1. chevy54man
    Joined: Feb 7, 2013
    Posts: 1,683

    chevy54man
    Member
    from NC

    Hey great car and build.....love what you're doing!
     
  2. mrconcdid
    Joined: Aug 31, 2010
    Posts: 1,157

    mrconcdid
    Member
    from Florida

    Glad to see your back at it, the cluster looks great.
    Looking at your top radiator hose the inlet on the engine looks higher than the fill of the radiator, you may have some air trap ( running hot ) issues if the fill is not the highest point in the cooling system. I ran into this on another build, the fix was to install another fill/cap inline of the upper radiator hose, Mr. Gasket makes a filler you can cut your top hose and put it inline, then just use it instead of the fill in the radiator.
    I'm still looking for pics of you cutting that hood!

    Keep going, spring is almost here
    Godspeed
    MrC.
     
  3. Schieri
    Joined: Jun 12, 2013
    Posts: 9

    Schieri
    Member
    from Swakopmund

    Great build, have you made any progress since the last you posted?
     
  4. mrconcdid
    Joined: Aug 31, 2010
    Posts: 1,157

    mrconcdid
    Member
    from Florida

    So where you been?, I swapped my 368 for a built 472 and LOVE it.
    We are still waiting to see that scoop through the hood picture!
    Also what water pump pulley did you use?
    IMG_20150102_214647_287.jpg
     

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2021 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.