Register now to get rid of these ads!

Help: TCI Mustang II and 1959 chevrolet apache

Discussion in 'The Hokey Ass Message Board' started by 59FleetsideTX, Feb 18, 2013.

  1. 59FleetsideTX
    Joined: Jan 24, 2011
    Posts: 7

    59FleetsideTX
    Member
    from Austin, TX

    Hoping one of you fine folks can help me. I have recently had a new TCI mustang ii front suspension installed under my '59 Chevy. After trailering the cab and chassis home from the installer, I noticed one of the rubber bushings on top of the shock tower was torn up. Assumed this was a factor of not having the full weight of the body panels on the front end. Installed those. But at full load it's obvious to me that the shocks appear to be too tall. That is, even with the nut and washer bottomed out on the threads there is play in the shock, the washer is not squeezing the bushing at all. Do I have the wrong shocks? Pic attached showing how far above the tower the threads are. any advice would be greatly appreciated. I'm a bit of a novice to say the least but am determined to learn and do as much as I can on my own.
    Thanks in advance,
    Brian
     

    Attached Files:

  2. 59FleetsideTX
    Joined: Jan 24, 2011
    Posts: 7

    59FleetsideTX
    Member
    from Austin, TX

    One more pic for reference.
     

    Attached Files:

  3. slow4dr
    Joined: Mar 31, 2011
    Posts: 32

    slow4dr
    Member
    from SoCal

    TCI uses a Monroe shock part # 32118.

    -J
     

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2020 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.