Register now to get rid of these ads!

brakes on my 64 c-10

Discussion in 'The Hokey Ass Message Board' started by mysteryman, Sep 10, 2011.

  1. mysteryman
    Joined: Apr 20, 2011
    Posts: 253

    mysteryman
    Member
    from atlanta

    i found myself in a scary situation couple weeks back.i was pulling a car on my trailer with my old 64.went to stop back tires slid but felt like there were no front brake at all.The truck was converted many years ago to 5 lug with disc brakes on front.any ideas on which direction to start to help resolve problem.Im runnig a dual mastercylinder with power booster.Part 2 of thread someone please explain how the proportional vave works.thanks in advance for any help.
     
  2. hoggyrubber
    Joined: Aug 30, 2008
    Posts: 572

    hoggyrubber
    Member

    i would start off by checking if both parts of the master has fluid in it. if they do i would take off a front tire and see if the piston in the caliper is working. that should let you know where to go. i was driving someone elses truck one time pulling a trailer and i didn't know they only had front brakes working. had a lot of tounge weight and steped on the brakes coming up on a stop light. front wheels locked up and slid thru like i hadn't even stepped on the brakes, and i wasn't even going very fast! not a lot of fun.
     

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2021 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.