Register now to get rid of these ads!

Projects Almost Funny - AWB Barracuda Funny Car Build

Discussion in 'The Hokey Ass Message Board' started by squirrel, Nov 27, 2017.

  1. Hemi Joel
    Joined: May 4, 2007
    Posts: 823

    Hemi Joel
    Member
    from Minnesota

    Hemi Squirrel, it's great to see you getting busy on the hemi again. What was wrong with the lifters? What is the plan for improvement?
     
  2. squirrel
    Joined: Sep 23, 2004
    Posts: 46,706

    squirrel
    Member

    Actually it's deprovement...going to flat tappet hydraulic lifters, while I sort out some other things with the car. But the lifter bores had been bushed, and need the oil slot and a bit of honing to let them move freely enough, and that requires taking it all apart to clean up the mess. I'll also hone the bores just a tad, and new rings. The main bearings have some interesting wear patterns, probably all normal stuff. I already put different valve springs in the heads.

    I also plan to look into the transmission, hopefully nothing looks amiss. And I have to fix several other things, like the gas pedal position, install the magneto and cable drive tach, and then figure out what to do about the fuel system. I might try some different carbs for now, and pursue the mechanical injection plan at some later time.
     
  3. If you are doing rings any thought to using hapless. I'm going to use them this year. Gapless second ring.
    Also upgrading to main studs might help out with the funny wear.
     
    enloe, Runnin shine and loudbang like this.
  4. Hemi Joel
    Joined: May 4, 2007
    Posts: 823

    Hemi Joel
    Member
    from Minnesota

    Zooming in on the pic, it looks like main studs are already there.
     
    loudbang and squirrel like this.
  5. squirrel
    Joined: Sep 23, 2004
    Posts: 46,706

    squirrel
    Member

    I'll keep the normal rings in it, I'm not really into "tricks" like real racers are. Yes, it has main studs.

    The mains all look like they had some metal to metal contact, yet the rods all look pretty good. No scoring or anything.
     
    enloe and loudbang like this.
  6. Hemi Joel
    Joined: May 4, 2007
    Posts: 823

    Hemi Joel
    Member
    from Minnesota

    Probably stuff you already know, But I would suggest double checking the main bore alignment, mabe have it align honed if it wasn't on the original build, and use p-series bearings.
     
    Last edited: Jan 27, 2020
    loudbang likes this.
  7. squirrel
    Joined: Sep 23, 2004
    Posts: 46,706

    squirrel
    Member

    The block was fully machined before I got it, I think he did a good job. The bearing surfaces are all like that, its not like something is out of line. More like it just takes a while to get oil to the mains? I'll have to get some pictures, I was kind of busy today.
     
    enloe and Stogy like this.
  8. AmishMike
    Joined: Mar 27, 2014
    Posts: 458

    AmishMike
    Member

    Machinest told me if going to use main studs, install them before align bored.
     
    loudbang likes this.
  9. squirrel
    Joined: Sep 23, 2004
    Posts: 46,706

    squirrel
    Member

    yeah, that's what was done with this one.
     
  10. mopacltd
    Joined: Nov 11, 2008
    Posts: 840

    mopacltd
    Member

    Hey Jim, where did you have the lifter bushings installed?
     
    loudbang likes this.
  11. squirrel
    Joined: Sep 23, 2004
    Posts: 46,706

    squirrel
    Member

    I didn't. The only block I could find to buy, already had a bunch of work done to it.
     
    kidcampbell71 likes this.

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2020 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.