Register now to get rid of these ads!

'51 Bucik Brake Problem

Discussion in 'The Hokey Ass Message Board' started by sled51merc, Jun 9, 2013.

  1. A buddy of mine is having a problem with his brakes and asked me to see what the fellas on the HAMB thought. So the problem is the brakes on his Buick are fine when he starts driving it but about ten miles later into the drive the pedal is rock hard and he can barely push it down at all. Everything is stock as far as master cylinder and wheel cylinders. He said he can bleed a wheel cylinder and it helps for a bit, but soon after the pedal is rock hard again. Any help would be appreciated!

    Thanks,

    sled
     
  2. BJR
    Joined: Mar 11, 2005
    Posts: 6,389

    BJR
    Member

    He has a bad brake hose. It lets fluid out to the wheel cylinder, but not back. Had the same thing happen to my 54 Buick. It was the rubber hose from the frame to the torque tube.
     
  3. Thanks for the input JBR! I'll let him know to check that.

    sled
     
  4. I mean BJR, sorry about that!

    sled
     
    Register now to get rid of these ads!

  5. landseaandair
    Joined: Feb 23, 2009
    Posts: 4,401

    landseaandair
    Member
    from phoenix

  6. He said once the pedal gets hard the brakes are engaged somewhat. Thanks for the suggestion in the thread, I'll check it out.

    sled


    Posted using the Full Custom H.A.M.B. App!
     

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2020 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.