Register now to get rid of these ads!

Technical 47 coupe fuel psi

Discussion in 'The Hokey Ass Message Board' started by mr. h, Jun 19, 2021.

  1. I have a 47 coupe original flathead but new fuel system, electric carter pump and tank and lines are new. It has never run well, has dual 97’s and fuel regulator. When I turn the key on I get 5 psi if I open the regulator up. When I crank it I lose all fuel pressure and it won’t start. I’ve turned the psi down to 3.5 where I want it and still nothing. I then blocked off the rear carb and fuel line straight to the front carb and same issue. Any ideas?
     
  2. Petejoe
    Joined: Nov 27, 2002
    Posts: 11,007

    Petejoe
    ALLIANCE MEMBER
    from Zoar, Ohio

    I’d first try changing out the regulator.
    I like running 2-1/2 to each Stromberg carb.
    Louisville?
    We were just there a few weeks ago eating at the Skratch steak house. Expensive but great steaks.
     
  3. I’ll give that a shot. Oh cool, I used to live in zoar on Michael lane.
     
    Petejoe likes this.
  4. jaracer
    Joined: Oct 4, 2008
    Posts: 1,154

    jaracer
    Member

    If you remove the line from the carb and turn on the pump, what kind of volume do you get? It should pump at least a pint in about 15 seconds. If it doesn't, you have something wrong with the pump or regulator.
     
    mr. h likes this.

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2021 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.