Register now to get rid of these ads!

351 Cleveland questions

Discussion in 'The Hokey Ass Message Board' started by hotrodwelder, Mar 8, 2009.

  1. hotrodwelder
    Joined: Sep 20, 2008
    Posts: 138

    hotrodwelder
    Member

    Here's my question; I have a mild 351C it doesnt see many rev's above 3-3500rpm, it's a streetable enginew/mild cam.

    What i'm getting is; it seems to blow a lot of oil out of the valve cover breathers, it has a PCV valve and everything is clean- no plugged hoses or lines, but this thing will oil my firewall and vave covers and makes a hell of a mess. It's a fresh motor w/ about 4k miles on it and it's getting old cleaning up after it. BTW the valve covers have baffles in them before and aft the vent holes.

    This is a question all my ford buddies can't answer.

    Could I get some ideas here, and no I'm not pulling it and putting in a Chevy!
     
  2. hotrod-Linkin
    Joined: Feb 7, 2007
    Posts: 3,382

    hotrod-Linkin
    Member

    broken ring or busted piston...time for a compression check
     
  3. X2...although I'd suspect rings that never sealed correctly.
     
  4. This is not a Ford question it is an engine question in general.
    This engine has a broken piston / rings.
    Do a compression test and find your dead hole.
     
    Register now to get rid of these ads!

  5. R A Wrench
    Joined: Feb 4, 2007
    Posts: 447

    R A Wrench
    Member
    from Denver, Co

    Agreed! Do a comp check, you are showing blow by. I have been running a 351C for many years with no problem.
     
  6. hotrodwelder
    Joined: Sep 20, 2008
    Posts: 138

    hotrodwelder
    Member

    I will give it a comp check and see what's up. Thanks!!!!!!
     
  7. Play400
    Joined: Nov 29, 2006
    Posts: 47

    Play400
    Member

    How much compression, distributor advance and what do you run for fuel? Thing ever ping? Only time I blew oil thru the breather was when I broke a ring land because of ping, the soft spring in the dizzy was dropping and holding the mechanical advance open at times. Found the problem when the second know good engine started to ping and the only thing we reused from the old set-up was the distributor. BTW a compression check did not highlight this problem as the piece seemed to fall back into place when testing.
     
  8. atlantic62
    Joined: Mar 8, 2009
    Posts: 1

    atlantic62
    Member

    Are you running synthetic oil ? Can't break an engine in on synthetic.does it smoke out the back too?
     
  9. hotrodwelder
    Joined: Sep 20, 2008
    Posts: 138

    hotrodwelder
    Member

    The Dist is a Mallory unilite w/ vacuum advance. 8.5:1 compression. Never ran synthetic oil and it doesnt smoke.

    My guess is the rings havent seated yet. My informants told me about ZDDP- zinc in the oil. This engine has a zinc additive in the oil, but maybe when it was in break-in period the oil was low on zinc, I dunno??

    Did I mention the oil comes from both sides of the engine.

    Thanks for the input guys..
     
  10. krooser
    Joined: Jul 25, 2004
    Posts: 4,585

    krooser
    Member

    The zinc wouldn't have any effect on ring seating... and many new cars use synthetiv oil as a factory fill these days.
     
  11. Play400
    Joined: Nov 29, 2006
    Posts: 47

    Play400
    Member

    I had a 351M and during the winter if the PVC became restrictive it almost immediately blow out the rear seal. Couldn't be something as simple as the PVC hose collapsing and then having the crankcase pressure and oil taking the easiest way out when back pedaling.
     

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2020 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.