Register now to get rid of these ads!

Technical 1950 Merc heater hose routing - looking for help

Discussion in 'Traditional Customs' started by timdhawk, Mar 25, 2021.

  1. timdhawk
    Joined: Aug 21, 2010
    Posts: 111

    timdhawk
    Member

    I have a 1950 Merc with a 302 in it. When I got it, it had no heater in it. I've redone factory heater parts and installed them, but I want to get some help with making sure the hoses are run correctly.
    From the water port on the intake manifold, where do I run my hose to first, the heater core or the heater valve? What's the correct routing for all the connections?

    20210324_132906.jpg
     
  2. Route from the intake manifold to the plunger side of the heater valve, from the other heater valve connection to the lower port of the heater core, and then from the top heater core port back to water pump.
     
    Pist-n-Broke likes this.
  3. young51
    Joined: May 11, 2009
    Posts: 27

    young51
    Member

    Believe it or not there is a mid 80's -90's jeep fan motor that bolts exactly into place of the Merc one pictured there yet is about half the length. 12volts and gives more clearance to the valve cover and tranny dipstick if you need it.
     
  4. twalberg
    Joined: Sep 22, 2019
    Posts: 2

    twalberg
    ALLIANCE MEMBER
    from Minnesota

    Try looking in the Concourse Parts catalog for the 49-59 big ford's book. I think page 130. It shows a decent basic diagram along with parts. It was helpful for me. They have a copy of the catalog online.

    Sent from my SM-G975U using The H.A.M.B. mobile app
     

Share This Page

Register now to get rid of these ads!

Archive

Copyright © 1995-2021 The Jalopy Journal: Steal our stuff, we'll kick your teeth in. Terms of Service. Privacy Policy.

Atomic Industry
Forum software by XenForo™ ©2010-2014 XenForo Ltd.