Welcome to the THE H.A.M.B. forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Go Back   THE H.A.M.B. > General Discussion > The Hokey Ass Message Board

Reply
 
Thread Tools Display Modes
Old 06-02-2004, 04:51 PM   #1
Slick mo fo
Grenade Inspector
 
Join Date: Feb 2003
Location: San Diego
Posts: 138
Default 351 Cleveland starting to run like shit

Latly my 351 C has been running a bit shitty. But it's been getting worse, and worse. I tinkered with the carb and that helped some for a little while, but went back to the shitty stage.
I replaced dist cap, roter, and plugs. No change.
I checked out the fuel filter and it looked clean. Fuel pressure is 7 lbs.
Here's the build;
351C bored .030
4V heads, closed chambers, stud mounted roller rockers
Mallory Unilite dist. (electricronic) vac adv.
MSD 6A
MSD 8mm wires
Holly 750 vac.
Weiand Excelerator intake
solid cam 226/300 dur @50* 540/560 lift
Mallory fuel pump, regulator, and filter
I also put port plates on the intake and exhaust for torque.

Now I thought it was running to rich, that's why I adjusted the carb. At idle it barely runs, but when giving the gas it gets running, but not that great. My thought is carb or distributer.
I'm going to limp over to JBA and have them tweek it out and dyno tune it.

Any thoughts on what might be going on?
or what I might try before taking it to the pro's?
offline   Reply With Quote
Old 06-02-2004, 04:56 PM   #2
Fat Hack
Old School HAMBer
 
Fat Hack's Avatar
 
Join Date: Nov 2002
Location: Detroit
Posts: 7,717
Default Re: 351 Cleveland starting to run like shit

Blown power valve in the carb?

Vacuum leak somewhere?

Garbage "hocus pocus" ignition system? ( )

Rocker arms loose/out of adjustment?

Compression test?

Timing off?

(Just ideas to get ya started)

offline   Reply With Quote
Old 06-02-2004, 05:14 PM   #3
1oldtimer
Old School HAMBer
 
1oldtimer's Avatar
 
Join Date: Aug 2003
Location: South Orange County, Ca.
Posts: 4,908
Default Re: 351 Cleveland starting to run like shit

i've seen more bad posts about the unilite dist. if you have another one you might try just swapping it (even if it's a points dist.). other then that i agree with hack.
offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Old 06-02-2004, 06:04 PM   #4
Slick mo fo
Grenade Inspector
 
Join Date: Feb 2003
Location: San Diego
Posts: 138
Default Re: 351 Cleveland starting to run like shit

I'm going to pull the valve covers off and check the rockers. I think I would hear those, but I have to change gaskets anyway (makeing a mess of my purdy Ford)

I'll also pop on the timing light, that's a quick check too.
Doubt if I lost compression. It's a fairly new build (but, shit does happen) and @ 11.5:1 CR, just maybe.
Is that power valve an easy thing to check? and where the hell is it?

Hey Oldtimer, wut up dood.
I think I still have my old dist with points. Don't remember what shape it was in. I'll check the boxes.
I heard the samething about that Unilite (after I bought it).
offline   Reply With Quote
Old 06-02-2004, 06:23 PM   #5
Fat Hack
Old School HAMBer
 
Fat Hack's Avatar
 
Join Date: Nov 2002
Location: Detroit
Posts: 7,717
Default Re: 351 Cleveland starting to run like shit

The power valve is located in the metering block behind the front float bowl on your 750 carb. If it's blown, it'll be leaking fuel into the venturis making it idle poorly and run rich all the time.

To check or replace it, you have to disconnect the fuel line and remove the four screws that hold the front bowl and metering block on. Original gaskets on some Holleys are a real motherfucker to get off...and will keep you busy for hours scraping the pieces off as they disintegrate...so be forewarned!

(Some newer Holleys come with anti-stick gaskets...a total Godsend for the masses!!)

The Power Valve will be the single kinda big round thing threaded into the middle of the metering block above the two primary main jets. It unscrews and removes easily.

Check the power valve with a hand-held vacuum pump...stick the suction cup over it and see if it works and holds...if it's blown, it won't move or hold vacuum.

Replacement valves are available at any decent speed shop...don't forget new gaskets, too!

(Power valves are also available in different vacuum ratings to tune the carb to your specific application...with radical cams, you often need a different power valve to keep it from trying to open at idle)

That said, I don't trust MSD ignitions or Unilite distributors...Clevelands earned their street creds with points distributors back in their brief but glorious hey-day...and that is still the best way to spark one up in my opinion!

Common sense troubleshooting will find and fix the problem...hang in there!

offline   Reply With Quote
Old 06-02-2004, 07:03 PM   #6
Slick mo fo
Grenade Inspector
 
Join Date: Feb 2003
Location: San Diego
Posts: 138
Default Re: 351 Cleveland starting to run like shit

Thanks Fat Hack.
I bet that's what it is.
I bet it was going bad, and then that day I gunned it getting on the freeway and it back fired thru the carb. I'm thinking that dusted it.
I'll check the timing after work.
Then I'll limp over to JBA. I'd much rather have them do it, they have the parts and the know how. Plus I don't have a vac. pump.


Question for ya, Will I be able to see it leaking with out taking it apart? Like thru the top of the carb.
offline   Reply With Quote
Old 06-02-2004, 07:54 PM   #7
Fat Hack
Old School HAMBer
 
Fat Hack's Avatar
 
Join Date: Nov 2002
Location: Detroit
Posts: 7,717
Default Re: 351 Cleveland starting to run like shit

Backfires are what normally blows out a power valve...although it won't do it EVERY time!

You MIGHT be able to see fuel dribbling into the venturis...but that could also happen if your float is stuck or set too high...so check your float level and condition while you got the bowl off.

offline   Reply With Quote
Old 06-03-2004, 04:54 PM   #8
Slick mo fo
Grenade Inspector
 
Join Date: Feb 2003
Location: San Diego
Posts: 138
Default Re: 351 Cleveland starting to run like shit

OK, last night I fired her up and I got her to idle. First thing I did was check timing, looked fine. Then check for vac leaks by spraying some wd40 around carb and intake, nothing happened. Except the main Vac out of the manifold that goes into the brake booster, but it was only very very slight and only happened once. So I tightened all the vac lines while I was there.

To check for internal vac leak I pulled out the PCV valve and pluged the hole going to the other valve cover. With both pluged, nothing happened, valve was working fine. Still ran the same.

I gave it a coupple revs and on the third time she back fired thru the carb and died. By now it's 10pm and my back yard is full of fumes. She started back up just fine, but still running like crap, like it's running on 5-6 cylinders. Cooled it down then sprayed her down with Simple green to clean off the wd40 and the leaking oil from the valve covers.

Tonigh when I get home, I'll pull the plugs to check them out.
I have an appointment at JBA in the morning. I have a strong feeling it's the power valve.

ya think?
offline   Reply With Quote
Old 06-03-2004, 11:13 PM   #9
1oldtimer
Old School HAMBer
 
1oldtimer's Avatar
 
Join Date: Aug 2003
Location: South Orange County, Ca.
Posts: 4,908
Default Re: 351 Cleveland starting to run like shit

still sounds like ignition...............
offline   Reply With Quote
Old 06-04-2004, 03:07 PM   #10
Slick mo fo
Grenade Inspector
 
Join Date: Feb 2003
Location: San Diego
Posts: 138
Default Re: 351 Cleveland starting to run like shit

OK.....
took it to JBA this morning. It was in the carb as I thought. Powervalve was leaking and they also re-jetted it.
Also due to the build, they recommended a larger carb & running 50/50 racing mix fuel, or octain boost with permium (which is what I run). They did dial it in on the dyno and she's running like a champ again.

Dyno;
316ft lb @ 2450 rpm
266 rwhp @6050 rpm (355 flywheel hp)
Not to shabby for a small block, eh?

Thanks for the input.
offline   Reply With Quote
Old 06-04-2004, 03:53 PM   #11
1oldtimer
Old School HAMBer
 
1oldtimer's Avatar
 
Join Date: Aug 2003
Location: South Orange County, Ca.
Posts: 4,908
Default Re: 351 Cleveland starting to run like shit

but i have been wrong before........
offline   Reply With Quote
Old 06-04-2004, 06:08 PM   #12
Slick mo fo
Grenade Inspector
 
Join Date: Feb 2003
Location: San Diego
Posts: 138
Default Re: 351 Cleveland starting to run like shit

It was possible...

maybe next time.
offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 01:54 AM.